Storygames Home City of IF
Free online storygaming
 

New Posts
Click here to go to the original topic

 
       Storygames Home -> Open Forum Archives
View previous topic :: View next topic  
Author Message
HalfEmptyHero



Joined: 16 Feb 2009
Posts: 342
Location: Where rolls the Oregon, and hears no sound

Posted: Sat May 28, 2011 11:57 am    Post subject: New Posts  

This has been annoying me quite some time now. Whenever I click the new posts link, the new posts doesn't go back to 0 afterwards. So if it says 13, I click on that and then click on one of those links, it remains 13. It will even add to that 13 when new posts happen. Sometimes it will add them, say go to 14 in this scenario, then I will click on new posts and nothing has changed. Is anyone else experiencing this behavior?
Back to top  
Smee



Joined: 16 Oct 2004
Posts: 5215
Location: UK

Posted: Sat May 28, 2011 12:07 pm    Post subject:  

It's new posts in your current login session.

If you exit the site for about 5 minutes, going back will reset the counter. But certainly for the way I look through posts, I need that list to be maintained for as long as it takes to get through all the new posts. I can't have it going to 0 the first time I click it.
Back to top  
HalfEmptyHero



Joined: 16 Feb 2009
Posts: 342
Location: Where rolls the Oregon, and hears no sound

Posted: Sat May 28, 2011 12:25 pm    Post subject:  

That's what tabs are for :) . But the thing is, it is never consistent. Sometimes it goes to zero, sometimes it doesn't. And the session thing is iffy as well, unless I log off.
Back to top  
Smee



Joined: 16 Oct 2004
Posts: 5215
Location: UK

Posted: Sat May 28, 2011 12:47 pm    Post subject:  

Losing internet connection for a second or two (quite frequent, especially on wireless connections) can be enough to reset it.
Back to top  
Shillelagh



Joined: 11 Mar 2010
Posts: 398
Location: Kansas

Posted: Sat May 28, 2011 12:48 pm    Post subject:  

My New Post counter doesn't reset until I close the window. And, if I have multiple browser windows/tabs open, I have to close every single one of them. Otherwise, the number just keeps growing every time I meander back to the site.
Back to top  
HalfEmptyHero



Joined: 16 Feb 2009
Posts: 342
Location: Where rolls the Oregon, and hears no sound

Posted: Sat May 28, 2011 12:56 pm    Post subject:  

Aha, that worked for me as well. I rarely close my browser, so that is a bit of an inconvenience.
Back to top  
Thunderbird



Joined: 13 Sep 2009
Posts: 2139
Location: Rising from the ashes

Posted: Sat May 28, 2011 1:26 pm    Post subject:  

What it sounds like, is you'd prefer the New Posts lists only showed posts you haven't gone into yet since the last time they received a reply?

Perhaps that would be a preferable way to go about that.

But we have some new tools for this sort of thing coming out soon that may make the site a bit easier to navigate where recent activity is concerned. If you have further complaint on the way the New Posts works, we can revisit the topic then.
Back to top  
The White Blacksmith



Joined: 02 Apr 2006
Posts: 2629

Posted: Sat May 28, 2011 1:31 pm    Post subject:  

You can still look at the little symbol next to the topic to see if you've read it. It changes colour, and while that may not show up in the total count, it's useful if you just want to skim down and check for any ones you've not checked.
Back to top  
Chinaren



Joined: 05 Sep 2005
Posts: 8797
Location: http://www.NeilHartleyBooks.com

Posted: Sat May 28, 2011 2:31 pm    Post subject:  

Mmmm, you know I didn't notice this until now.

I'm fairly sure it didn't used to do that. Maybe the recent coding changes have affected this?
Back to top  
Ingrothechundyer



Joined: 22 Aug 2010
Posts: 484
Location: Wandering the streets of IF since 10/21/2005

Posted: Sat May 28, 2011 2:39 pm    Post subject:  

Chinaren wrote: Mmmm, you know I didn't notice this until now.

I'm fairly sure it didn't used to do that. Maybe the recent coding changes have affected this?

There shouldn't be any coding changes on the main forum that would effect this (actually there shouldn't be any coding changes that effect this)

AFIK it's done that ever since I re-created my account. It was one of the things I distinctly remember finding annoying when coming back (along with my account being gone in the first place)

~~~

Now what I find very interesting is that it doesn't do it consistently. I have one computer that the session does indeed end and the New posts lists resets and another where I have never seen it do so without me having to close my browser.
Back to top  
HalfEmptyHero



Joined: 16 Feb 2009
Posts: 342
Location: Where rolls the Oregon, and hears no sound

Posted: Sat May 28, 2011 2:43 pm    Post subject:  

Chinaren wrote: Mmmm, you know I didn't notice this until now.

I'm fairly sure it didn't used to do that. Maybe the recent coding changes have affected this?
That was what I thought. I knew I wasn't crazy.
Back to top  
Ingrothechundyer



Joined: 22 Aug 2010
Posts: 484
Location: Wandering the streets of IF since 10/21/2005

Posted: Sat May 28, 2011 4:26 pm    Post subject:  

HalfEmptyHero wrote: Chinaren wrote: Mmmm, you know I didn't notice this until now.

I'm fairly sure it didn't used to do that. Maybe the recent coding changes have affected this?
That was what I thought. I knew I wasn't crazy.

Hmm I'm scratching my head here.

I went digging into the code and the recent posts are based off of the user's last visit. This is unchanged from the copy that was in place before I made any modifications. EDIT: The last change to the copy in general use was 5/9/2010 according to the server.

sessions.php wrote: $last_visit = ( $userdata['user_session_time'] > 0 ) ? $userdata['user_session_time'] : $current_time;
The only place that I can find the session time being set is in session_begin function in the sessions.php file which hasn't been modified since 4/26/2008

The only places I can find it being called is when you login or if your session doesn't exist. In both cases they haven't been modified since 4/26/2008

~~~

I'm sure this behavior can be changed if the majority wants it. This change will have ramifications beyond just the new posts if we change it though (RSS and new PM notifications were what I saw with a quick search)
Back to top  
HalfEmptyHero



Joined: 16 Feb 2009
Posts: 342
Location: Where rolls the Oregon, and hears no sound

Posted: Sun May 29, 2011 2:49 am    Post subject:  

I don't know what is up with it, but it is extremely buggy. I have screenshots to prove it, I am just too lazy to post them up right now, but it seems to add to the number of new posts at random, but the posts showing up in new posts haven't changed at all. The number also seems to always be wrong.
Back to top  
Ingrothechundyer



Joined: 22 Aug 2010
Posts: 484
Location: Wandering the streets of IF since 10/21/2005

Posted: Sun May 29, 2011 2:56 am    Post subject:  

Do you have a few minutes? I want to try something and see if it effects what you are seeing.
Back to top  
HalfEmptyHero



Joined: 16 Feb 2009
Posts: 342
Location: Where rolls the Oregon, and hears no sound

Posted: Sun May 29, 2011 2:58 am    Post subject:  

I've got 20 min to be precise.
Back to top  
Ingrothechundyer



Joined: 22 Aug 2010
Posts: 484
Location: Wandering the streets of IF since 10/21/2005

Posted: Sun May 29, 2011 2:59 am    Post subject:  

Works for me. Can you join the Inn?
Back to top  
Ingrothechundyer



Joined: 22 Aug 2010
Posts: 484
Location: Wandering the streets of IF since 10/21/2005

Posted: Sun May 29, 2011 3:08 am    Post subject:  

Thank you for helping me look into this.

The problem appears to be that posts in hidden forums do not *show* when you view the recent posts list but they do *appear* in the "New posts" count thus showing a higher number of new posts then you can actually see which seems like it would be highly annoying.

Adding to my list of things to get around to fixing one day...
Back to top  
Ingrothechundyer



Joined: 22 Aug 2010
Posts: 484
Location: Wandering the streets of IF since 10/21/2005

Posted: Sun May 29, 2011 5:17 am    Post subject:  

HalfEmptyHero wrote: I don't know what is up with it, but it is extremely buggy. I have screenshots to prove it, I am just too lazy to post them up right now, but it seems to add to the number of new posts at random, but the posts showing up in new posts haven't changed at all. The number also seems to always be wrong.

Fixed.
Back to top  
Crunchyfrog



Joined: 12 Dec 2006
Posts: 3998

Posted: Sun May 29, 2011 5:27 am    Post subject:  

Ingro you are truly amazing with what you're achieving here :cool:



Ummm.... I don't know if it is just me or if I've sailed in just as you're tinkering with something, but right now all the forums are missing from the main message boards. I mean, they're there all right, because I navigated to this thread by the Recent Posts link - but - there's no forum display. o-)

And even weirder, I can see them all when logged out. :shock:
Back to top  
Smee



Joined: 16 Oct 2004
Posts: 5215
Location: UK

Posted: Sun May 29, 2011 5:38 am    Post subject:  

Me too!
Back to top  
Ingrothechundyer



Joined: 22 Aug 2010
Posts: 484
Location: Wandering the streets of IF since 10/21/2005

Posted: Sun May 29, 2011 5:39 am    Post subject:  

Not sure what I did but I'm looking into it now...

EDIT: Fixed. Looking into what went wrong...
Back to top  
Ingrothechundyer



Joined: 22 Aug 2010
Posts: 484
Location: Wandering the streets of IF since 10/21/2005

Posted: Sun May 29, 2011 5:47 am    Post subject:  

Crunchyfrog wrote: Ummm.... I don't know if it is just me or if I've sailed in just as you're tinkering with something, but right now all the forums are missing from the main message boards. I mean, they're there all right, because I navigated to this thread by the Recent Posts link - but - there's no forum display. o-)

And even weirder, I can see them all when logged out. :shock:

Good catch!

Thank you for letting me know so fast.

Fixed (and the New posts count is working again as well).
Back to top  
Thunderbird



Joined: 13 Sep 2009
Posts: 2139
Location: Rising from the ashes

Posted: Mon May 30, 2011 11:54 am    Post subject:  

I've been missing a bit thanks to yesterday's Net outage but you seem to be doing a great job here Ingro... thanks!
Back to top  
 
       Storygames Home -> Open Forum Archives
Page 1 of 1


Powered by phpBB Search Engine Indexer
Powered by phpBB 2.0.16 © 2001, 2002 phpBB Group